sleepycow

HPLIP:Mint/Ubuntu驱动HP打印机的注意事项
介绍HPLIP (HP Linux Imaging and Printing) 是一个惠普公司发起和领导的项目,其...
扫描右侧二维码阅读全文
12
2018/08

HPLIP:Mint/Ubuntu驱动HP打印机的注意事项

介绍

HPLIP (HP Linux Imaging and Printing) 是一个惠普公司发起和领导的项目,其目标是让 Linux 系统,能够完成支持惠普的喷墨打印机和激光打印机的打印,扫描和传真功能。它所提供的驱动程序,共支持1980部HP打印机型号。

Linux Mint / Ubuntu 软件源中都有 hplip(版本稍旧),安装起来非常方便。而 Linux Mint 更是已经搭载了 hplip,对于一般的喷墨打印机,比如 hp deskjet 1000/2050 等,可谓真正的即插即用。只要连接好打印机的数据线,系统会自动添加打印机,数秒即可完成,并且马上可以打印了。而对于多数激光打印机和较新的型号,需要到 hplip 官网下载最新版的 hplip 和 hplip-plugin(插件)才能驱动起来。

hplip 下载地址
hplip-plugin 下载地址

常见问题和注意事项

1.hplip-plugin的版本必须和hplip版本一致
2.使用普通用户权限安装hplip,即不要用sudo,安装过程中会要求你输入的
3.安装过程中如果出现“cups-image”依赖问题,请在终端中先安装如下软件,再运行hplip安装程序

sudo apt-get install hpijs hpijs-ppds hplip-cups

4.如果遇到的出错提示是“CUPSEXT could not be loaded. Please check HPLIP installation.”,请在终端中先安装如下软件,再运行hplip安装程序

sudo apt-get install hplip-gui hplip hplip-cups hplip-data hpijs hpijs-ppds libcupsimage2-dev

5.安装成功后无法启动HP Device Manager(惠普设备管理器及托盘小图标),可以在终端中运行hp-systray,查看出错信息。(一般都是文件夹权限问题)

Last modification:August 12th, 2018 at 01:12 pm
If you think my article is useful to you, please feel free to appreciate

Leave a Comment